How to Configure Default Routing in Cisco Routers?

Author:

This lesson uses a real-world Packet Tracer example to demonstrate how to set up and use a default route in routing. Learn how to set up Cisco routers’ default routing.

A router verifies the packet’s destination network address as it arrives on one of its interfaces and locates that address in the routing table. The inbound packet is forwarded from the interface specified in the entry if the router discovers an entry for the destination network.

Default Route On Cisco Router

The router looks at the default route if it cannot locate an entry for the destination network. The router forwarded the incoming packet from the interface indicated in the default route if the default route was available.

The router drops the incoming packet if the default route is not available. All incoming packets are sent using a default route by the router even though the routing table does not contain the destination addresses.

The following circumstances typically call for the adoption of a default route to route each packet to a specific destination.

For logging and troubleshooting purposes, it is necessary to route all unknown packets—those whose destination network addresses are not listed in the routing table—to a server or device.

to send every packet to a device or router that has the ability to access remote networks or has a routing table with entries for every remote network.

Static Routes Configuration

The following IOS commands can be used to configure a static route.

Router(config)#ip route target network subnet mask default gateway [administrative distance] [permanent]

OR

ip route destination network subnet mask interface to exit Router(config)# [administrative distance] [permanent]

See also  192.168.100.1

Even if the interface the router uses for the static route fails, the permanent keyword will retain the route in the routing table.

Static Routing – Laboratory Exercise

If you’re not familiar with how to connect a router console, click the following link to find out how to connect your computer’s serial port to a router console port.

If your computer lacks a serial port, click the following link to learn how to connect to the router’s console port.

To learn how to setup a router using the HyperTerminal and PuTTY terminal emulators, click the links below.

Configuring the hostname and IP address on Router01

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Router01
Router01(config)#

Use the following IOS commands to configure host name as Router01 while connected to Router01 console.

Open the fast ethernet interface Fa0/0 configuration mode on Router01 by using the following IOS commands, and set the IP address to 172.16.0.1/16.

Router02>enable
Router02#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router02(config)#interface fa0/0
Router02(config-if)#ip address 172.18.0.1 255.255.0.0
Router02(config-if)#no shutdown

Open the serial interface S0/0 configuration mode on Router01 and set the IP address to 172.17.0.1/16 using the IOS commands listed below. Since this is the DCE side, you must additionally establish a clock rate using the “clock rate” instruction on the S0/0 interface.

Router02>enable
Router02#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router02(config)#interface s0/0
Router02(config-if)#ip address 172.17.0.2 255.255.0.0
Router02(config-if)#no shutdown

If you wish to save the changes you’ve made to the router, remember to use the “copy running-config startup-config” command from enable mode.

Router02>enable
Router02#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router02(config)#interface s0/1
Router02(config-if)#clock rate 64000
Router02(config-if)#ip address 172.19.0.1 255.255.0.0
Router02(config-if)#no shutdown

Configuring the hostname and IP address in Router02

Use the following IOS commands to configure host name as Router02 while connected to Router02 console.

See also  How to Change Your IP Address?

Open the fast ethernet interface Fa0/0 configuration mode on Router02 using the following IOS commands, and set the IP address to 172.18.0.1/16.

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Router03
Router03(config)#

Open the serial interface S0/0 configuration mode on Router02 and set the IP address to 172.17.0.2/16 using the IOS commands listed below.

Router03>enable
Router03#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router03(config)#interface fa0/0
Router03(config-if)#ip address 172.20.0.1 255.255.0.0
Router03(config-if)#no shutdown

Open the serial interface S0/1 setup mode on Router02 and set the IP address to 172.19.0.1/16 using the IOS commands listed below. Since this is the DCE side, you must additionally establish a clock rate using the “clock rate” instruction on the S0/1 interface.

If you wish to save the changes you’ve made to the router, remember to use the “copy running-config startup-config” command from enable mode.

Router03>enable
Router03#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router03(config)#interface s0/1
Router03(config-if)#ip address 172.19.0.2 255.255.0.0
Router03(config-if)#no shutdown

Check out the below video for detail:

Leave a Reply

Your email address will not be published.